Back to overview
Degraded
Email delivery disruption
Oct 24 at 03:33am HDT
Affected services
Email
Resolved
Oct 24 at 07:38am HDT
We’ve rolled out a fix, and all previously queued outbound emails have now been successfully delivered to end users.
Please reach out to our support team if you have any questions or need further details.
Affected services
Created
Oct 24 at 03:33am HDT
We’re investigating an issue where emails sent through our email service are not being delivered. Our team is working to identify the root cause and restore normal delivery as quickly as possible.
Affected services